+2 votos
531 visitas

Estou montando uma instalação do WES do zero, configurei o aplicativo no IIS e tentei abrir para configurar sistema, etc e ocorre este erro.

Não foi possível carregar arquivo ou assembly 'IronPython, Version=2.7.8.0, Culture=neutral, PublicKeyToken=7f709c5b713576e1' ou uma de suas dependências. A definição do manifesto do assembly localizado não corresponde à referência do assembly

por (539 pontos) | 531 visitas

1 Resposta

+1 voto
Melhor resposta
O problema é a versão da dll do IronPython, está exigindo a versão 2.7.8.0 e no binário contem apenas a versão 2.0.

Este problema ocorre devido a confusão de dlls no binário, existem dlls de duas versões do WES misturadas.

Esta confusão ocorre pq os binários do WES no sistema Corporativo estão no GIT, e o dev trocou de branch, porém o arquivo gitexclude não está completamente configurado e acabou ficando dlls de uma versão mais nova misturadas com as dlls da versão velha.

Para resolver basta excluir todo o diretório de bintários e sincronizar com o git (já que o git contem todas as dlls necessárias).
por (539 pontos)
Melhores Jun 2021
  1. KlaraHarriet

    5 Pontos

  2. Roger Dias

    5 Pontos

  3. PNJ Sharptech

    5 Pontos

  4. alexlong9578

    5 Pontos

  5. LinGhh440168

    5 Pontos

200 pontos
Melhores 2021 Jun 14 - 20
  1. henrique.muller

    28 Pontos

  2. willian.metalsystem

    19 Pontos

  3. Cesar.Albuquerque

    11 Pontos

  4. rubem.oliota

    8 Pontos

  5. KlaraHarriet

    5 Pontos

  6. maicon.pereira

    5 Pontos

  7. rafael.paludo

    2 Pontos

  8. thiago.pereira

    2 Pontos

  9. alessandro.souza

    2 Pontos

  10. paulo.larini

    2 Pontos

490 perguntas
494 respostas
357 comentários
546 usuários